We are continuing to monitor for any further issues.
Posted Nov 10, 2025 - 20:21 CET
Monitoring
Our hosting services has been hacked during the night of November 9th. All our teams are actively working to solve the this problem as soon as possible.
Posted Nov 10, 2025 - 15:54 CET
This incident affected: All website (imators.com/.tech/.be/.ch/...), Imators Systems, formore, and Can.